Mac Book AirにHomebrewとgnuplotを導入

研究でgnuplotが使いたくなったので、インストールすることにした

公式サイトよりインストールして使ってみると、なにやら図形描写がされない
どうやらOSX Marvericsになってから (というかMountain Lionから?)勝手が違うらしい
 X11が使えなくなったっぽい

うーん、IT音痴には意味がわかりません、、、、
とりあえず、X11の代わりにAquatermってやつを入れればいいらしい!!!

そうして再インストールしてみたけど、結局グラフ描写されねー!!!!!

もういいー!!!!

ん??なになに??
Homebrewとかいう便利なのがあるの?
しかもなんだか調べてみると、これを使ってGnuplotをインストールするやり方なら、結構な情報量がありそうだ


というわけで、
Homebrewインストールした
この辺を参考に。
http://maezono.info/2013/12/14/1350
 
とはいってもコマンド一発なんだけど!

まぁとりあえず無事導入出来ました


そしてようやくGnuplotの導入だけど、Mountain LionまではHomebrewですぐにインストールできていたみたいなんだけど、Marvericsになってからは更に変な事になっているっぽい

なんだよもー

とはいっても、探してみたらありました
 http://qiita.com/jtwp470/items/09f8aea31d172bd4acc7

これを参考にすればオッケーじゃん!!

と思ったけど、自分の環境では出来ない

Warning: gnuplot-4.6.5 already installed, it's just not linked  

あ、前のやつ消さなきゃー

brew uninstall gnuplot 
Uninstalling /usr/local/Cellar/gnuplot/4.6.5...  

そして改めてインストール!!

brew install gnuplot 

とおもいきや、以下のエラーメッセージが、、、
==> Downloading https://downloads.sourceforge.net/project/gnuplot/gnuplot/4.6.5/Already downloaded: /Library/Caches/Homebrew/gnuplot-4.6.5.tar.gz==> ./configure --disable-silent-rules --prefix=/usr/local/Cellar/gnuplot/4.6.5 ==> make==> make install==> CaveatsAquaTerm support will only be built into Gnuplot if the standard AquaTermpackage from SourceForge has already been installed onto your system.If you subsequently remove AquaTerm, you will need to uninstall and thenreinstall Gnuplot.Error: The `brew link` step did not complete successfullyThe formula built, but is not symlinked into /usr/localYou can try again using:  brew link gnuplot 


と言われたので、言われるがままに
brew link gnuplot 
のコマンドを実行

しかし、
> Linking /usr/local/Cellar/gnuplot/4.6.5...> Error: Could not symlink share/emacs/site-lisp/gnuplot.el> /usr/local/share/emacs/site-lisp is not writable 

とか言われた
アクセス権限変えないとダメだったのか
というわけで、
sudo chmod o+w site-lisp/ 

をやって無事完了しましたー!